Notify Message
Forums
Page 1
Search
#14304368 Feb 08, 2020 at 02:41 PM · Edited 4 months ago
Commander
52 Posts
The launcher for SWTOR requires admin privileges to start for some reason that no one can understand. This can cause issues for some overlay applications and applications that want to register global hot keys (such as Discord and TeamSpeak) since they need to be started with elevated as well - but you can't have a program start with that on computer start. So we all have to keep restarting those apps to get everything working.

I've found a workaround for this issue that makes the launcher think it's running in elevated mode, but it really isn't. Best of all, there are no ugly register hacks or changed binaries! That said - it still isn't trivial.
Proceed at your own risk.

To get it working, follow these steps:
  1. Download and install Microsoft Windows ADK.
  2. Once installed, launch `Compatibility Administrator (32-bit)` - don't use the 64-bit version, SWTOR is 32-bit so that's what we need to use.
  3. Right click 'Custom database' and select 'New'.
  4. Once the database has been creaded, select the new database right click it and `Create new -> Application fix`
  5. Enter whatever you want for the first two fields, for the 'Program file location' you select the launcher executable (Default: `C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic\launcher.exe`)
  6. Click 'Next' until you reach the page named 'Compatability Fixes`- make sure that you activate the fix 'ForceAdminAccess' but checking the box to the left of that option.
  7. Click 'Next` and on the next page I would deselect all fields having `VERSION` in the name so that you don't have to do this the next time the launcher is updated...
  8. Click `Finish`
  9. Right click the database and select 'Install'

The next time you launch the game, it should not request to be elevated. I've been running like this for at least one minor patch now - and have seen no adverse effects.
+2
#14305697 Feb 10, 2020 at 08:11 AM · Edited 4 months ago
104 Posts
Just curious. Wouldent setting the run as administrator checkbox make sure it started in admin mode?

https://pasteboard.co/IU0p4Gs.png
+1
#14311471 Feb 18, 2020 at 06:50 PM
Commander
52 Posts
Yes it would. But that's not the goal. the goal is to make the launcher think it runs in admin mode while it actually doesn't.
+0
Page 1